Back to overview
Degraded

Courier API Performance Issues

Mar 23, 2026 at 11:10am UTC
Affected services
API
Courier Integration

Resolved
Mar 23, 2026 at 02:32pm UTC

We have confirmed the root cause of the issue and confirmed that services are fully operational again.

Created
Mar 23, 2026 at 11:10am UTC

We're currently aware of performance issues from Courier API, affecting existing shipments and integrations. We're investigating these issues and will provide further updates.