Back to overview
Resolved
External Carrier API Issues
Jul 27, 2026 at 10:31am UTC
Affected services
Courier Integration
Resolved
Jul 27, 2026 at 3:11pm UTC
We've confirmed externally that the carrier issues are now resolved.
Affected services
Created
Jul 27, 2026 at 10:31am UTC
We're currently aware of delays from external carrier APIs which may intermittently affect shipments. We're continuing to monitor this and are actively chasing to resolve these issues as soon as possible.
Affected services