Back to overview
Downtime
FTP Connection Issues
Oct 27 at 12:27pm BST
Resolved
Oct 27 at 12:42pm BST
The issue has now been resolved.
Affected services
Created
Oct 27 at 12:27pm BST
We are working through some FTP connection issues and will bring the service back online as fast a we can.
Affected services