Back to overview
Degraded
RF Degradation Issue
Jun 15 at 12:10pm BST
Affected services
HHD
Resolved
Jun 15 at 01:00pm BST
We have identified the cause of the issue, and resolved it. RF appears to be working correctly again.
Affected services
HHD
Created
Jun 15 at 12:10pm BST
Currently some of our users are experiencing issues with their RF, including errors, blank screens, and logouts. We're currently working to fix this issue as soon as possible.
Affected services
HHD